WallStyleComponentCollection Class

This class represents a collection of wall style components.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.Arch.DatabaseServicesWallStyleComponentCollection

Namespace: Teigha.Aec.Arch.DatabaseServices
Assembly: TA_MgdArch (in TA_MgdArch.dll) Version: 0.0.0.0
Syntax
public sealed class WallStyleComponentCollection : IList

The WallStyleComponentCollection type exposes the following members.

Constructors
  Name Description
Public method WallStyleComponentCollection Default constructor for the Segment2dCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a wall style component at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified wall style component as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified wall style component.
Public method CopyTo Copies this collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of wall style component.
Public method IndexOf Returns the index of the wall style component in the collection that matches the specified wall style component.
Public method Insert Inserts the specified wall style component to the collection at the provided index.
Public method Remove Removes a wall style component that matches the specified wall style component from the collection.
Public method RemoveAt Removes a wall style component from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.