Segment2dCollection Class

This class represents a collection of 2D segments.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.GeometrySegment2dCollection

Namespace: Teigha.Aec.Geometry
Assembly: TA_Mgd (in TA_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Segment2dCollection : IList

The Segment2dCollection type exposes the following members.

Constructors
  Name Description
Public method Segment2dCollection Default constructor for the Segment2dCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a segment at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified segment as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified segment.
Public method CopyTo Copies this segment collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of segments.
Public method IndexOf Returns the index of the segment in the collection that matches the specified segment.
Public method Insert Inserts the specified segment to the collection at the provided index.
Public method Remove Removes a segment that matches the specified segment from the collection.
Public method RemoveAt Removes a segment from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.