FaceRef Class

This .NET class wraps the OdDbFaceRef class.

This class represents a reference to a face.

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesGeomRef
          Teigha.DatabaseServicesSubentRef
            Teigha.DatabaseServicesFaceRef

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class FaceRef : SubentRef

The FaceRef type exposes the following members.

Constructors
  Name Description
Public method FaceRef Default constructor for the FaceRef class. Creates an object that wraps a corresponding C++ OdDbFaceRef object.
Public method FaceRef(CompoundObjectId) Constructor for the FaceRef class. Creates a face reference based on the specified compound object.
Public method FaceRef(CompoundObjectId, SubentityId) Constructor for the FaceRef class. Creates a face reference based on the specified compound object.
Top
Properties
  Name Description
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.