PageParamsCollection Class

This class represents a collection of page parameters objects.
Inheritance Hierarchy
SystemObject
  System.CollectionsCollectionBase
    Teigha.GraphicsSystemPageParamsCollection

Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class PageParamsCollection : CollectionBase

The PageParamsCollection type exposes the following members.

Constructors
  Name Description
Public method PageParamsCollection Default constructor for the PageParamsCollection class. Creates an empty collection of page parameters.
Top
Properties
  Name Description
Public property Item Property that represents an item from the collection at the specified index.
Top
Methods
  Name Description
Public method Add Adds a page parameters object to the end of this collection. This method grows the collection capacity if necessary.
Public method Contains Checks whether this collection contains the specified object.
Public method CopyTo Copies the specified array to this collection at the specified index.
Public method IndexOf Returns an index in the collection of the specified page parameters object.
Public method Insert Inserts the specified object to the collection at the provided index.
Protected method OnValidate
(Overrides CollectionBaseOnValidate(Object))
Public method Remove Removes the specified object from the collection.
Top
See Also

©  Bricsys NV. All rights reserved.