SubentityOverruleMoveGripPointsAtSubentPaths
Method
|
Overrules the
Entity.subMoveGripPointsAtSubentPaths() method and calls it in the
default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void MoveGripPointsAtSubentPaths(
Entity entity,
FullSubentityPath[] path,
GripDataCollection grips,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
Public Overridable Sub MoveGripPointsAtSubentPaths (
entity As Entity,
path As FullSubentityPath(),
grips As GripDataCollection,
offset As Vector3d,
bitFlags As MoveGripPointsFlags
)
public:
virtual void MoveGripPointsAtSubentPaths(
Entity^ entity,
array<FullSubentityPath>^ path,
GripDataCollection^ grips,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
abstract MoveGripPointsAtSubentPaths :
entity : Entity *
path : FullSubentityPath[] *
grips : GripDataCollection *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
override MoveGripPointsAtSubentPaths :
entity : Entity *
path : FullSubentityPath[] *
grips : GripDataCollection *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
Parameters
- entity Entity
- [in] Entity.
- path FullSubentityPath
- [in] Array of full subentity path objects identifying the
subentities to be moved.
- grips GripDataCollection
- [in] Array of pointers referring to each grip point to be
moved.
- offset Vector3d
- [in] Vector that indicates the direction and magnitude of the
translation to be applied to the grips.
- bitFlags MoveGripPointsFlags
- [in] Mask of one or more flags specified by the
MoveGripPointsFlags enumeration.
See Also