FileStreamBuf Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeStreamBuf
          Teigha.RuntimeFileStreamBuf

Namespace: Teigha.Runtime
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class FileStreamBuf : StreamBuf

The FileStreamBuf type exposes the following members.

Constructors
  Name Description
Public method FileStreamBuf(String) Initializes a new instance of the FileStreamBuf class
Public method FileStreamBuf(String, Boolean) Initializes a new instance of the FileStreamBuf class
Public method FileStreamBuf(String, Boolean, FileShareMode) Initializes a new instance of the FileStreamBuf class
Public method FileStreamBuf(String, Boolean, FileShareMode, FileCreationDisposition) Initializes a new instance of the FileStreamBuf class
Top
Properties
  Name Description
Public property FileName
(Overrides StreamBufFileName)
Public property IsEof
(Overrides StreamBufIsEof)
Public property Length
(Overrides StreamBufLength)
Public property ShareMode
(Overrides StreamBufShareMode)
Public property Tell
(Overrides StreamBufTell)
Top
Methods
  Name Description
Public method CopyTo(StreamBuf, UInt64, UInt64)
(Overrides StreamBufCopyTo(StreamBuf, UInt64, UInt64))
Public method Read
(Overrides StreamBufRead)
Public method Read(UInt32)
(Overrides StreamBufRead(UInt32))
Public method Rewind
(Overrides StreamBufRewind)
Public method Seek
(Overrides StreamBufSeek(Int64, FilerSeekType))
Public method Truncate
(Overrides StreamBufTruncate)
Public method Write(Byte)
(Overrides StreamBufWrite(Byte))
Public method Write(Byte, UInt32)
(Overrides StreamBufWrite(Byte, UInt32))
Top
See Also

©  Bricsys NV. All rights reserved.