DimRadial object

Class AcadDimRadial

Member of BricscadDb

A dimension measuring the radius of a circle or arc. To create a radial dimension, use the AddDimRadial method. To access the DimRadial object, use the following methods and properties:


Methods Properties
ArrayPolar AltRoundDistance
ArrayRectangular AltSuppressLeadingZeroes
Copy AltSuppressTrailingZeroes
Delete AltSuppressZeroFeet
GetBoundingBox AltSuppressZeroInches
GetExtensionDictionary AltTextPrefix
GetXData AltTextSuffix
Highlight AltTolerancePrecision
IntersectWith AltToleranceSuppressLeadingZeroes
Mirror AltToleranceSuppressTrailingZeroes
Mirror3D AltToleranceSuppressZeroFeet
Move AltToleranceSuppressZeroInches
Rotate AltUnits
Rotate3D AltUnitsFormat
ScaleEntity AltUnitsPrecision
SetXData AltUnitsScale
TransformBy Application
Update ArrowheadBlock
  ArrowheadSize
  ArrowheadType
  CenterMarkSize
  CenterType
  DecimalSeparator
  DimensionLineColor
  DimLineSuppress
  Document
  ExtensionLineOffset
  Fit
  ForceLineInside
  FractionFormat
  Handle
  HasExtensionDictionary
  HorizontalTextPosition
  Hyperlinks
  Layer
  LeaderLength
  LinearScaleFactor
  Linetype
  LinetypeScale
  Lineweight
  Measurement
  Normal
  ObjectID
  ObjectName
  OwnerID
  PlotStyleName
  PrimaryUnitsPrecision
  Rotation
  RoundDistance
  ScaleFactor
  StyleName
  SuppressLeadingZeroes
  SuppressTrailingZeroes
  SuppressZeroFeet
  SuppressZeroInches
  TextColor
  TextGap
  TextHeight
  TextInside
  TextInsideAlign
  TextMovement
  TextOutsideAlign
  TextOverride
  TextPosition
  TextPrecision
  TextPrefix
  TextRotation
  TextString
  TextStyle
  TextSuffix
  ToleranceDisplay
  ToleranceHeightScale
  ToleranceJustification
  ToleranceLowerLimit
  TolerancePrecision
  ToleranceSuppressLeadingZeroes
  ToleranceSuppressTrailingZeroes
  ToleranceSuppressZeroFeet
  ToleranceSuppressZeroInches
  ToleranceUpperLimit
  TrueColor
  UnitsFormat
  VerticalTextPosition
  Visible

© Bricsys NV. All rights reserved.