Ellipse object

Class AcadEllipse

Member of BricscadDb

The Ellipse object represents an elliptical arc or full ellipse. To create an ellipse use the AddEllipse method. To access the Ellipse object, use the following methods and properties.


Methods Properties
ArrayPolar Application
ArrayRectangular Area
Copy Center
Delete Document
GetBoundingBox EndAngle
GetExtensionDictionary EndParameter
GetXData EndPoint
Highlight Handle
IntersectWith HasExtensionDictionary
Mirror Hyperlinks
Mirror3D Layer
Move Length
Offset Linetype
 Rotate LinetypeScale
Rotate3D Lineweight
ScaleEntity MajorAxis
SetXData MajorRadius
TransformBy Material *
Update MinorAxis
  MinorRadius
  Normal
  ObjectID
  ObjectName
  OwnerID
  PlotStyleName
  RadiusRatio
  StartAngle
  StartParameter
  StartPoint
  TrueColor
  Visible

© Bricsys NV. All rights reserved.