CurveCurveIntersector3d Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class CurveCurveIntersector3d : Entity3d

The CurveCurveIntersector3d type exposes the following members.

Constructors
  Name Description
Public method CurveCurveIntersector3d
Initializes a new instance of the CurveCurveIntersector3d class
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d)
Initializes a new instance of the CurveCurveIntersector3d class
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Vector3d, Tolerance)
Initializes a new instance of the CurveCurveIntersector3d class
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d)
Initializes a new instance of the CurveCurveIntersector3d class
Public method CurveCurveIntersector3d(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance)
Initializes a new instance of the CurveCurveIntersector3d class
Top
Properties
Methods
  Name Description
Public method ChangeCurveOrder
Public methodStatic member Create
Public method GetIntersectionParameters
Public method GetIntersectionPoint
Public method GetIntersectionPointTolerance
Public method GetIntersectionRanges
Public method GetOverlapRanges
Public method GetPointOnCurve1
Public method GetPointOnCurve2
Public method IsTangential
Public method IsTransversal
Public method OrderWithRegardsTo1
Public method OrderWithRegardsTo2
Public method OverlapCount
Public method OverlapDirection
Public method Set(Curve3d, Curve3d, Vector3d)
Public method Set(Curve3d, Curve3d, Vector3d, Tolerance)
Public method Set(Curve3d, Curve3d, Interval, Interval, Vector3d)
Public method Set(Curve3d, Curve3d, Interval, Interval, Vector3d, Tolerance)
Top
See Also

©  Bricsys NV. All rights reserved.