Material Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class Material : DBObject

The Material type exposes the following members.

Constructors
  Name Description
Public method Material
Initializes a new instance of the Material class
Top
Properties
  Name Description
Public property Ambient
Public property Anonymous
Public property Bump
Public property ChannelFlags
Public property ColorBleedScale
Public property Description
Public property Diffuse
Public property FinalGather
Public property GlobalIllumination
Public property IlluminationModel
Public property IndirectBumpScale
Public property Luminance
Public property LuminanceMode
Public property Mode
Public property Name
Public property NormalMap
Public property Opacity
Public property ReflectanceScale
Public property Reflection
Public property Reflectivity
Public property Refraction
Public property SelfIllumination
Public property Specular
Public property Translucence
Public property TransmittanceScale
Public property TwoSided
Top
Methods
  Name Description
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.