AssocArrayPathParameters Class |
This .NET class wraps the OdDbAssocArrayPathParameters class.
It provides an interface for managing array path parameters.
The AssocArrayPathParameters type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AssocArrayPathParameters |
Default constructor for the
AssocArrayPathParameters class. Creates an object that wraps a
corresponding default OdDbAssocArrayPathParameters C++
object.
|
![]() |
AssocArrayPathParameters(Double, Double, Double, Int32, Int32, Int32, Double) |
Constructor for the AssocArrayPathParameters
class. Creates an object with the specified spacing, count and
elevation parameters.
|
Name | Description | |
---|---|---|
![]() |
AlignItems | |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
BaseNormal | (Inherited from AssocArrayCommonParameters.) |
![]() |
BasePlane | (Inherited from AssocArrayCommonParameters.) |
![]() |
BasePoint | (Inherited from AssocArrayCommonParameters.) |
![]() |
EndOffset | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
ItemCount | |
![]() |
ItemSpacing | |
![]() |
LevelCount | (Inherited from AssocArrayCommonParameters.) |
![]() |
LevelSpacing | (Inherited from AssocArrayCommonParameters.) |
![]() |
Method | |
![]() |
Owner |
Retrieves the associative array.
(Inherited from AssocArrayParameters.) |
![]() |
Path | |
![]() |
PathDirection | |
![]() |
RowCount | (Inherited from AssocArrayCommonParameters.) |
![]() |
RowElevation | (Inherited from AssocArrayCommonParameters.) |
![]() |
RowSpacing | (Inherited from AssocArrayCommonParameters.) |
![]() |
StartOffset | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
Commit |
Commits the changes that are stored in the
AssocArrayParameters object and synchronizes the changes with the
database. When AssocArrayParameters does not have an owner, no
changes are committed.
(Inherited from AssocArrayParameters.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetEndOffset |
Retrieves the end offset of the path array.
The end offset is only available when using the MethodType.Divide
arrangement type. If there is no expression for a particular
parameter, the expression and the
evaluatorId strings are empty after the
method executes.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetItemCount |
Retrieves the item count of the path array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
|
![]() |
GetItemSpacing |
Retrieves the item spacing of the path array.
If there is no expression for a particular parameter, the
expression and the evaluatorId strings are empty after the method
executes.
|
![]() |
GetLevelCount |
Retrieves the level count of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetLevelSpacing |
Retrieves the level spacing of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRowCount |
Retrieves the row count of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRowElevation |
Retrieves the row elevation of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRowSpacing |
Retrieves the row spacing of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetStartOffset |
Retrieves the start spacing of the path array.
If there is no expression for a particular parameter, the
expression and the evaluatorId strings are empty after the method
executes.
|
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
SetEndOffset |
Sets the end offset of the path array. The end
offset is only available when using the MethodType.Divide
arrangement type. If there is no expression for a particular
parameter, the expression and the
evaluatorId strings must be empty.
|
![]() |
SetItemCount |
Sets the item count of the path array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
|
![]() |
SetItemSpacing |
Sets the item spacing of the path array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
|
![]() |
SetLevelCount |
Sets the level count for this array. If there
is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetLevelSpacing |
Sets the level spacing for this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowCount |
Sets the row count for this array. If there is
no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowElevation |
Sets the row elevation for this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowSpacing |
Sets the row spacing for this array. If there
is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetStartOffset |
Sets the start offset of the path array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |