AssocDependency Class |
This .NET class wraps the OdDbAssocDependency class.
The AssocDependency class provides information about which associative actions (AssocActions instances) depend on or modify corresponding database objects. The associativity in drawings is represented exactly in this manner.
Associative actions own dependencies which are then attached to the objects as persistent reactors.
The AssocDependency type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AssocDependency |
Default constructor for the AssocDependency
class. Creates an object that wraps the corresponding C++
AssocDependency object with default parameters.
|
Name | Description | |
---|---|---|
![]() |
AddContext | (Inherited from DBObject.) |
![]() |
AddPersistentReactor | (Inherited from DBObject.) |
![]() |
ApplyPartialUndo | (Inherited from DBObject.) |
![]() |
AssertNotifyEnabled | (Inherited from DBObject.) |
![]() |
AssertReadEnabled | (Inherited from DBObject.) |
![]() |
AssertWriteEnabled | (Inherited from DBObject.) |
![]() |
AttachToObject |
Attaches this dependency to one or more
objects as a persistent reactor. It also places this dependency in
the correct position in the list of dependencies on the
object.
|
![]() |
Audit | (Inherited from DBObject.) |
![]() |
Cancel | Obsolete. (Inherited from DBObject.) |
![]() |
Clone | (Inherited from RXObject.) |
![]() |
Close | Obsolete. (Inherited from DBObject.) |
![]() |
CloseAndPage | Obsolete. (Inherited from DBObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateExtensionDictionary | (Inherited from DBObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DecomposeForSave | (Inherited from DBObject.) |
![]() |
DeepClone | (Inherited from DBObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from DBObject.) |
![]() |
DetachFromObject |
Detaches this dependency from the database
object and removes it from the list of persistent reactors of the
dependent-on-object.
|
![]() |
DisableUndoRecording | (Inherited from DBObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DBObject.) |
![]() |
DowngradeOpen | (Inherited from DBObject.) |
![]() |
DowngradeToNotify | (Inherited from DBObject.) |
![]() |
DwgIn | (Inherited from DBObject.) |
![]() |
DwgInFields | (Inherited from DBObject.) |
![]() |
DwgOut | (Inherited from DBObject.) |
![]() |
DwgOutFields | (Inherited from DBObject.) |
![]() |
DxfIn | (Inherited from DBObject.) |
![]() |
DxfInFields | (Inherited from DBObject.) |
![]() |
DxfOut | (Inherited from DBObject.) |
![]() |
DxfOutFields | (Inherited from DBObject.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Erase | (Inherited from DBObject.) |
![]() |
Erase(Boolean) | (Inherited from DBObject.) |
![]() |
Evaluate |
Updates "irrelevant" dependencies of the
association action.
|
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() ![]() |
GetDependenciesOnObject |
Retrieves the dependencies on the specified
database object.
|
![]() |
GetEventExtender | (Inherited from DBObject.) |
![]() |
GetField | (Inherited from DBObject.) |
![]() |
GetField(String) | (Inherited from DBObject.) |
![]() ![]() |
GetFirstDependencyOnObject |
Retrieves the first dependency on the
specified database object.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetObjectSaveVersion(DwgFiler) | (Inherited from DBObject.) |
![]() |
GetObjectSaveVersion(DxfFiler) | (Inherited from DBObject.) |
![]() |
GetPersistentReactorIds | (Inherited from DBObject.) |
![]() |
GetReactors | Obsolete. (Inherited from DBObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetTransientReactors | (Inherited from DBObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
GetXDataForApplication | (Inherited from DBObject.) |
![]() |
HandOverTo | (Inherited from DBObject.) |
![]() |
HasContext | (Inherited from DBObject.) |
![]() |
HasPersistentReactor | (Inherited from DBObject.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
NotifyDependenciesOnObject |
Sends the new association status to all
dependencies of the specified object.
|
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
ReleaseExtensionDictionary | (Inherited from DBObject.) |
![]() |
RemoveContext | (Inherited from DBObject.) |
![]() |
RemoveField | (Inherited from DBObject.) |
![]() |
RemoveField(String) | (Inherited from DBObject.) |
![]() |
RemoveField(ObjectId) | (Inherited from DBObject.) |
![]() |
RemovePersistentReactor | (Inherited from DBObject.) |
![]() |
ResetScaleDependentProperties | (Inherited from DBObject.) |
![]() |
SetAttributes | (Inherited from Drawable.) |
![]() |
SetDependentOnObject |
Sets the dependent-on-object of this
dependency to be the specified compoundId
parameter.
|
![]() |
SetField(Field) | (Inherited from DBObject.) |
![]() |
SetField(String, Field) | (Inherited from DBObject.) |
![]() |
SetFromStyle | (Inherited from DBObject.) |
![]() |
SetObjectIdsInFlux | (Inherited from DBObject.) |
![]() |
SetPaperOrientation | (Inherited from DBObject.) |
![]() |
SetStatus |
Sets the dependent-on-object of this
dependency to be the specified compoundId
parameter.
|
![]() |
SubSetAttributes | (Inherited from DBObject.) |
![]() |
SubViewportDraw | (Inherited from DBObject.) |
![]() |
SubViewportDrawLogicalFlags | (Inherited from DBObject.) |
![]() |
SubWorldDraw | (Inherited from DBObject.) |
![]() |
SupportsCollection | (Inherited from DBObject.) |
![]() |
SwapIdWith | (Inherited from DBObject.) |
![]() |
SwapReferences | (Inherited from DBObject.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
UpdateDependentOnObject |
Updates the object on which the dependency
depends, based on the information obtained by the dependency from
the parent action.
|
![]() |
UpgradeFromNotify | (Inherited from DBObject.) |
![]() |
UpgradeOpen | (Inherited from DBObject.) |
![]() |
ViewportDraw | (Inherited from Drawable.) |
![]() |
ViewportDrawLogicalFlags | (Inherited from Drawable.) |
![]() |
WblockClone | (Inherited from DBObject.) |
![]() |
WorldDraw | (Inherited from Drawable.) |
![]() |
X | (Inherited from RXObject.) |
![]() |
XDataTransformBy | (Inherited from DBObject.) |
Name | Description | |
---|---|---|
![]() |
Cancelled | (Inherited from DBObject.) |
![]() |
Copied | (Inherited from DBObject.) |
![]() |
Erased | (Inherited from DBObject.) |
![]() |
Goodbye | (Inherited from DBObject.) |
![]() |
Modified | (Inherited from DBObject.) |
![]() |
ModifiedXData | (Inherited from DBObject.) |
![]() |
ModifyUndone | (Inherited from DBObject.) |
![]() |
ObjectClosed | (Inherited from DBObject.) |
![]() |
OpenedForModify | (Inherited from DBObject.) |
![]() |
Reappended | (Inherited from DBObject.) |
![]() |
SubObjectModified | (Inherited from DBObject.) |
![]() |
Unappended | (Inherited from DBObject.) |
© Bricsys NV. All rights reserved. |