AssocArrayRectangularParameters Class |
This .NET class wraps the OdDbAssocArrayRectangularParameters class.
It provides an interface for managing polar array parameters.
The AssocArrayRectangularParameters type exposes the following members.
Name | Description | |
---|---|---|
![]() |
AssocArrayRectangularParameters |
Default constructor for the
AssocArrayRectangularParameters class. Creates an object that wraps
the corresponding C++ OdDbAssocArrayRectangularParameters object
with default parameters.
|
![]() |
AssocArrayRectangularParameters(Double, Double, Double, Int32, Int32, Int32, Double, Double) |
Constructor for the AssocArrayPolarParameters
class. Creates an object with the specified spacing, count and
angle parameters.
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
AxesAngle | |
![]() |
BaseNormal | (Inherited from AssocArrayCommonParameters.) |
![]() |
BasePlane | (Inherited from AssocArrayCommonParameters.) |
![]() |
BasePoint | (Inherited from AssocArrayCommonParameters.) |
![]() |
ColumnCount | |
![]() |
ColumnSpacing | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
LevelCount | (Inherited from AssocArrayCommonParameters.) |
![]() |
LevelSpacing | (Inherited from AssocArrayCommonParameters.) |
![]() |
Owner |
Retrieves the associative array.
(Inherited from AssocArrayParameters.) |
![]() |
RowCount | (Inherited from AssocArrayCommonParameters.) |
![]() |
RowElevation | (Inherited from AssocArrayCommonParameters.) |
![]() |
RowSpacing | (Inherited from AssocArrayCommonParameters.) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
XAxisDirection | |
![]() |
YAxisDirection |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
Commit |
Commits the changes that are stored in the
AssocArrayParameters object and synchronizes the changes with the
database. When AssocArrayParameters does not have an owner, no
changes are committed.
(Inherited from AssocArrayParameters.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetAxesAngle |
Retrieves the angle between the first row and
first column of the rectangular array. If there is no expression
for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
|
![]() |
GetColumnCount |
Retrieves the column count of the rectangular
array. If there is no expression for a particular parameter, the
expression and the evaluatorId strings are empty after the method
executes.
|
![]() |
GetColumnSpacing |
Retrieves the column spacing of the
rectangular array. If there is no expression for a particular
parameter, the expression and the
evaluatorId strings are empty after the
method executes.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLevelCount |
Retrieves the level count of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetLevelSpacing |
Retrieves the level spacing of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRowCount |
Retrieves the row count of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRowElevation |
Retrieves the row elevation of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRowSpacing |
Retrieves the row spacing of this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings are empty after the method
executes.
(Inherited from AssocArrayCommonParameters.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
SetAxesAngle |
Sets the angle between the first column and
first row in the polar array. If there is no expression for a
particular parameter, the expression and
the evaluatorId strings must be
empty.
|
![]() |
SetColumnCount |
Sets the column count of the rectangular
array. If there is no expression for a particular parameter, the
expression and the evaluatorId strings must be empty.
|
![]() |
SetColumnSpacing |
Sets the column spacing of the rectangular
array. If there is no expression for a particular parameter, the
expression and the evaluatorId strings must be empty.
|
![]() |
SetLevelCount |
Sets the level count for this array. If there
is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetLevelSpacing |
Sets the level spacing for this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowCount |
Sets the row count for this array. If there is
no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowElevation |
Sets the row elevation for this array. If
there is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
SetRowSpacing |
Sets the row spacing for this array. If there
is no expression for a particular parameter, the expression and the evaluatorId strings must be empty.
(Inherited from AssocArrayCommonParameters.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |