BIMBuilding Class

Inheritance Hierarchy
Namespace:  Bricscad.Bim
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public class BIMBuilding : BIMSpatialLocation

The BIMBuilding type exposes the following members.

Constructors
  Name Description
Public method BIMBuilding
Initializes a new instance of the BIMBuilding class
Public method BIMBuilding(BIMBuilding)
Initializes a new instance of the BIMBuilding class
Top
Properties
Methods
  Name Description
Public methodStatic member AllObjectBuildings
Public method AllObjectStories
Public methodStatic member AllObjectStories(Database, String)
Public methodStatic member AllStringBuildings
Public method AllStringStories
Public methodStatic member AllStringStories(Database, String)
Public methodStatic member AssignedBuilding
Public method AssignToEntity
Public methodStatic member Cast
Public method CreateBuilding(String, Database)
Public methodStatic member CreateBuilding(Database, String)
Public method CreateStory
Public method DeleteBuilding(Database)
Public methodStatic member DeleteBuilding(Database, String)
Public method DeleteStory(String)
Public method DeleteStory(BIMStory)
Public method GetAssignedObjects
Public methodStatic member GetBuilding
Public method GetStory
Public method IsNull (Overrides BIMSpatialLocationIsNull.)
Public method SetNull (Overrides BIMSpatialLocationSetNull.)
Top
Operators
  Name Description
Public operatorStatic member Equality
Public operatorStatic member Inequality
Top
See Also

©  Bricsys NV. All rights reserved.