ClipBoundary Class

This class is used to pass clip boundary specifications from drawable objects to the underlying OdGi system.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GraphicsInterfaceClipBoundary

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class ClipBoundary : DisposableWrapper

The ClipBoundary type exposes the following members.

Constructors
  Name Description
Public method ClipBoundary Default constructor for the ClipBoundary class. Constructs an empty clip boundary.
Top
Properties
  Name Description
Public property BackClipZ Property that represents the distance from a target point to the back clipping plane.
Public property ClippingBack Property that represents a flag that indicates whether back clipping is enabled.
Public property ClippingFront Property that represents a flag that indicates whether front clipping is enabled.
Public property DrawBoundary Property that represents a flag that indicates whether drawing the clip boundary is enabled.
Public property FrontClipZ Property that represents the distance from a target point to the front clipping plane.
Public property NormalVector Property that represents a normal vector that defines the plane in which the clip boundary lies.
Public property Point Property that represents an origin of the clipping boundary.
Public property TransformInverseBlockRefXForm Property that represents a transformation matrix from BlockSpace to WorldSpace.
Public property TransformToClipSpace Property that represents a transformation matrix from ModelSpace to ClipSpace.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.