RingCollection Class

This class represents a collection of rings.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.GeometryRingCollection

Namespace: Teigha.Aec.Geometry
Assembly: TA_Mgd (in TA_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class RingCollection : IList

The RingCollection type exposes the following members.

Constructors
  Name Description
Public method RingCollection Default constructor for the RingCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a ring at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified ring as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified ring.
Public method CopyTo Copies this ring collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of rings.
Public method IndexOf Returns the index of the ring in the collection that matches the specified ring.
Public method Insert Inserts the specified ring to the collection at the provided index.
Public method Remove Removes a ring that matches the specified ring from the collection.
Public method RemoveAt Removes a ring from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.