BIMComposition Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMComposition

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMComposition : BIMObject

The BIMComposition type exposes the following members.

Constructors
  Name Description
Public method BIMComposition Initializes a new instance of the BIMComposition class
Public method BIMComposition(BIMComposition) Initializes a new instance of the BIMComposition class
Public method BIMComposition(String) Initializes a new instance of the BIMComposition class
Top
Properties
  Name Description
Public property Comments  
Public property Layer  
Public property Type  
Public property VariablePlyIndex  
Top
Methods
  Name Description
Public methodStatic member AddMaterialsAndCompositionsFromXML  
Public methodStatic member AllObjectCompositions  
Public methodStatic member AllStringCompositions  
Public method AssignToEntity(ObjectId, Double)  
Public methodStatic member AssignToEntity(String, ObjectId, Double)  
Public methodStatic member AvailableObjectCompositions  
Public methodStatic member AvailableStringCompositions  
Public methodStatic member Cast  
Public method DeleteComposition  
Public methodStatic member DeleteComposition(Database, String, Boolean)  
Public methodStatic member DeleteMaterial  
Public methodStatic member GetAssignedCompositionName  
Public methodStatic member GetAssignedCompositionObject  
Public method GetAssignedObjects  
Public methodStatic member GetComposition  
Public method GetPlyAt  
Public methodStatic member HasComposition  
Public method NumberOfPlies  
Public methodStatic member RemoveCompositionFrom  
Public method SaveComposition  
Public methodStatic member SaveComposition(BIMComposition, Database, Boolean)  
Public method SetPlyAt  
Public method SetToNull
(Overrides BIMObjectSetToNull)
Public method VariablePlyThickness  
Top
Operators
See Also

©  Bricsys NV. All rights reserved.