BIMObject Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        More

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public abstract class BIMObject : DisposableWrapper

The BIMObject type exposes the following members.

Constructors
  Name Description
Protected method BIMObject Initializes a new instance of the BIMObject class
Top
Properties
  Name Description
Public property BimType  
Public property BimTypeName  
Public property Description  
Public property GetTypeDesc Obsolete.
Public property GetTypeName Obsolete.
Public property isNull  
Public property Name  
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method IsNull Obsolete.
Public method SetNull Obsolete.
Public method SetToNull  
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMComposition
        Bricscad.BimBIMMaterial
        Bricscad.BimBIMPly
        Bricscad.BimBIMRoom
        Bricscad.BimBIMSpatialLocation

©  Bricsys NV. All rights reserved.