SlabLoopCollection Class

This class represents a collection of slab loops.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.Arch.GeometrySlabLoopCollection

Namespace: Teigha.Aec.Arch.Geometry
Assembly: TA_MgdArch (in TA_MgdArch.dll) Version: 0.0.0.0
Syntax
public sealed class SlabLoopCollection : IList

The SlabLoopCollection type exposes the following members.

Constructors
  Name Description
Public method SlabLoopCollection Default constructor for the SlabLoopCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a slab loop at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified slab loop as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified slab loop.
Public method CopyTo Copies this collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of slab loops.
Public method IndexOf Returns the index of the slab loop in the collection that matches the specified slab loop.
Public method Insert Inserts the specified slab loop to the collection at the provided index.
Public method Remove Removes a slab loop that matches the specified slab loop from the collection.
Public method RemoveAt Removes a slab loop from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.