Shadow
|
The ShadowParameters type exposes the following members.
Name | Description | |
---|---|---|
![]() |
ShadowParameters | Default constructor for the ShadowParameters class. Constructs shadow parameters with default properties: * Enabled shadows. * Shadow map softness. * Light shape visibilty disabled. * Shadow type is ray traced. * Shadow map size is 256. * Shadow samples is 16. * Extended light shape is a sphere. * The length of the extended light source is 0.0. * The width of the extended light source is 0.0. * The radius of the extended light source is 0.0. |
![]() |
ShadowParameters(IntPtr, Boolean) | Initializes a new instance of the ShadowParameters class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
ExtendedLightLength | |
![]() |
ExtendedLightRadius | |
![]() |
ExtendedLightShape | |
![]() |
ExtendedLightWidth | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
ShadowMapSize | |
![]() |
ShadowMapSoftness | |
![]() |
ShadowSamples | |
![]() |
ShadowsOn | |
![]() |
ShadowType | |
![]() |
ShapeVisibility | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | Checks objects for equality. (Overrides DisposableWrapperEquals(Object)) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | Retrieves the object hash code. (Overrides DisposableWrapperGetHashCode) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |