Ring Class

AEC 2D ring that is a closed 2D curve.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.Aec.DatabaseServicesImpObject
          Teigha.Aec.GeometryCompoundCurve2d
            Teigha.Aec.GeometryRing
              Teigha.Aec.Arch.GeometrySlabLoop

Namespace: Teigha.Aec.Geometry
Assembly: TA_Mgd (in TA_Mgd.dll) Version: 24.2.0.0
Syntax
public class Ring : CompoundCurve2d

The Ring type exposes the following members.

Constructors
  Name Description
Public method Ring Default constructor for the Ring class.
Protected method Ring(IntPtr, Boolean) Initializes a new instance of the Ring class
Top
Properties
  Name Description
Public property Area Property that represents the area of the ring.
Public property Centroid Property that represents the center of mass.
Public property Segments  
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.