ImpObject Class

Abstract base class for AEC sub-objects.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.Aec.DatabaseServicesImpObject
          More

Namespace: Teigha.Aec.DatabaseServices
Assembly: TA_Mgd (in TA_Mgd.dll) Version: 24.2.0.0
Syntax
public class ImpObject : RXObject

The ImpObject type exposes the following members.

Constructors
  Name Description
Public method ImpObject Default constructor for the ImpObject class.
Protected method ImpObject(IntPtr, Boolean) Initializes a new instance of the ImpObject class
Top
Properties
  Name Description
Public property Database Property that represents the database owning this object.
Public property Description Property that represents the description text of the object.
Top
Methods
  Name Description
Public method SetToStandard Sets this object to be in the specified database.
Public method SubSetDatabaseDefaults Sets this object to be in the specified database.
Top
See Also
Inheritance Hierarchy

©  Bricsys NV. All rights reserved.