GeometricalConstraint Class

This class implements a constrained geometry node in the owning constraint group. It is the base class for all constraints.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesConstraintGroupNode
          Teigha.DatabaseServicesGeometricalConstraint
            Teigha.DatabaseServicesExplicitConstraint

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class GeometricalConstraint : ConstraintGroupNode

The GeometricalConstraint type exposes the following members.

Properties
  Name Description
Public property ConnectedGeometries Property that represents the array of handles to the constrain geometrical objects which are connected to this constraint.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.