GenericTexture Class

This class defines generic procedural material textures.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceMaterialTexture
          Teigha.GraphicsInterfaceProceduralTexture
            Teigha.GraphicsInterfaceGenericTexture

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class GenericTexture : ProceduralTexture, 
        ICloneable

The GenericTexture type exposes the following members.

Constructors
  Name Description
Public method GenericTexture Default constructor for the GenericTexture class.
Top
Properties
  Name Description
Public property Definition Property that represents the definition object containing the procedural texture data.
Top
Methods
  Name Description
Public method Clone Clones current texture.
(Overrides RXObjectClone)
Public method CopyFrom(GenericTexture) Copies parameters of the specified texture.
Public method Equals Checks objects for equality.
(Overrides DisposableWrapperEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides DisposableWrapperGetHashCode)
Public method Set Sets parameters from the specified texture.
Top
Operators
  Name Description
Public operatorStatic member Equality(GenericTexture, GenericTexture) Equality operator for the GenericTexture class.
Public operatorStatic member Inequality(GenericTexture, GenericTexture) Inequality operator for the GenericTexture class.
Top
See Also

©  Bricsys NV. All rights reserved.