Line2dCollection Class

This class represents a collection of 2d lines.
Inheritance Hierarchy
SystemObject
  Teigha.GeometryLine2dCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Line2dCollection : IList

The Line2dCollection type exposes the following members.

Constructors
  Name Description
Public method Line2dCollection Default constructor for the Line2dCollection class. Creates an empty collection of 2d lines.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents an item from the collection at the specified index.
Top
Methods
  Name Description
Public method Add Adds a line to the collection.
Public method Clear Clears this collection of 2d lines.
Public method Contains  
Public method CopyTo Copies this line collection to specified array at the specified index.
Public method GetEnumerator Returns enumerator for this lines collection.
Public method IndexOf Returns index of the line in collection that matches the specified line.
Public method Insert Inserts the specified value to the collection at the provided index.
Public method Remove Removes a line in the collection that matches the specified line.
Public method RemoveAt Removes a line from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.