BIMLinearGeometry Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMLinearGeometry

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMLinearGeometry : DisposableWrapper

The BIMLinearGeometry type exposes the following members.

Constructors
  Name Description
Public method BIMLinearGeometry Initializes a new instance of the BIMLinearGeometry class
Public method BIMLinearGeometry(BIMLinearGeometry) Initializes a new instance of the BIMLinearGeometry class
Public method BIMLinearGeometry(ObjectId) Initializes a new instance of the BIMLinearGeometry class
Top
Properties
  Name Description
Public property Axis  
Public property EndFaces  
Public property EndPoint  
Public property EntityId  
Public property ExtrusionPath  
Public property isValid  
Public property Profile  
Public property ProfileCurves  
Public property SideFaces  
Public property StartPoint  
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method GetAssignedProfile Obsolete.
Public method GetAxis Obsolete.
Public method GetClippingFaces Obsolete.
Public method GetEndPoint Obsolete.
Public method GetExtrusionPath Obsolete.
Public method GetId Obsolete.
Public method GetProfile Obsolete.
Public method GetSideFaces Obsolete.
Public method GetStartPoint Obsolete.
Public method IsValid Obsolete.
Public method SetId Obsolete.
Top
See Also

©  Bricsys NV. All rights reserved.