TrimPlaneCollection Class

This class represents a collection of trim planes.
Inheritance Hierarchy
SystemObject
  Teigha.Aec.Structural.DatabaseServicesTrimPlaneCollection

Namespace: Teigha.Aec.Structural.DatabaseServices
Assembly: TA_MgdStructure (in TA_MgdStructure.dll) Version: 0.0.0.0
Syntax
public sealed class TrimPlaneCollection : IList

The TrimPlaneCollection type exposes the following members.

Constructors
  Name Description
Public method TrimPlaneCollection Constructor for the TrimPlaneCollection class.
Top
Properties
  Name Description
Public property Count Represents the number of elements that this collection currently stores.
Public property Item Property that represents a trim plane at the specified index.
Top
Methods
  Name Description
Public method Add Adds the specified trim plane as the next object in the collection.
Public method Clear Erases all items from the collection.
Public method Contains Checks whether this collection contains the specified trim plane.
Public method CopyTo Copies this collection to the specified array at the specified index.
Public method GetEnumerator Returns the enumerator for this collection of trim planes.
Public method IndexOf Returns the index of the trim plane in the collection that matches the specified trim plane.
Public method Insert Inserts the specified trim plane to the collection at the provided index.
Public method Remove Removes a trim plane that matches the specified trim plane from the collection.
Public method RemoveAt Removes a trim plane from the collection at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.