action = "(string)";
Execute this LISP function.
This attribute is a callback that executes a
function when the user clicks a given tile.
For string, specify the name of a LISP function.
Example
action =
"(function)";
NOTE
- Note that the tile action, known as a callback
function, is more usually specified by the controlling program
using the action_tile function. If an action is defined by the
calling program, the DCL-specifed action is ignored.
- The action attribute cannot call an
function.
- A tile can have only one action assigned to it,
and action_tile overrides action if assigned by the program.
- Do not include the sds_command function in the
action
function.
Valid Tiles
button
popup_list
edit_box
multi_edit_box
radio_button
image_button
slider
list_box
toggle
Tell me about...
Programming
Overview of DCL (Dialog Control Language)
About
Predefined Attributes
Programming
Overview of LISP (LISt Processing) Language
Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV
are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved. |