BIMAttributeSet Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMAttributeSet

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 25.1.5.0
Syntax
public class BIMAttributeSet : DisposableWrapper

The BIMAttributeSet type exposes the following members.

Constructors
  Name Description
Public method BIMAttributeSet Initializes a new instance of the BIMAttributeSet class
Public method BIMAttributeSet(BIMAttributeSet) Initializes a new instance of the BIMAttributeSet class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member AddBimType  
Public methodStatic member CreateAttributeSet  
Public methodStatic member CreateProperty  
Public methodStatic member DelBimType  
Public methodStatic member DeleteAttributeSet  
Public methodStatic member DeleteProperty(ObjectId, String, String)  
Public methodStatic member DeleteProperty(String, String, Database)  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public methodStatic member GetLabel  
Public methodStatic member GetParameters  
Public methodStatic member GetProperty  
Public methodStatic member GetPropertyParameters  
Public methodStatic member HasAttributeSet  
Public methodStatic member HasBimType  
Public methodStatic member HasProperty(ObjectId, String, String)  
Public methodStatic member HasProperty(String, String, Database)  
Public methodStatic member ListAllBimTypes  
Public methodStatic member ListAttributeSets  
Public methodStatic member ListBimTypes  
Public methodStatic member ListProperties  
Public methodStatic member SetLabel  
Public methodStatic member SetParameters  
Public methodStatic member SetProperty  
Public methodStatic member SetPropertyParameters  
Top
See Also

©  Bricsys NV. All rights reserved.