Polyline object

Class AcadPolyline

Member of BricscadDb

The Polyline object represents a drawing entity composed of one or more connected line or arc segments treated as a single entity. To create a polyline, use the AddPolyline method. To edit or obtain information about a line, use the following methods and properties:


Methods Properties
AppendVertex Application
ArrayPolar Area
ArrayRectangular Closed
Copy ConstantWidth
Delete Coordinate
Explode Coordinates
GetBoundingBox Document
GetBulge Elevation
GetExtensionDictionary Handle
GetWidth HasExtensionDictionary
GetXData Hyperlinks
Highlight Layer
IntersectWith Length
Mirror Linetype
Mirror3D LinetypeGeneration
Move LinetypeScale
Offset Lineweight
Rotate Material
Rotate3D Normal
ScaleEntity ObjectID
SetBulge ObjectName
SetWidth OwnerID
SetXData PlotStyleName
TransformBy Thickness
Update TrueColor
  Visible

© Bricsys NV. All rights reserved.