BIMMaterial Class |
The BIMMaterial type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BIMMaterial |
Initializes a new instance of the BIMMaterial class
|
![]() |
BIMMaterial(String) |
Initializes a new instance of the BIMMaterial class
|
![]() |
BIMMaterial(BIMMaterial) |
Initializes a new instance of the BIMMaterial class
|
Name | Description | |
---|---|---|
![]() |
Appearance | |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Comments | |
![]() |
CutPattern | |
![]() |
Description | (Overrides BIMObjectDescription.) |
![]() |
GetTypeDesc | (Overrides BIMObjectGetTypeDesc.) |
![]() |
GetTypeName | (Overrides BIMObjectGetTypeName.) |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
Name | (Overrides BIMObjectName.) |
![]() |
SurfacePattern | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() ![]() |
AllObjectsMaterials | |
![]() ![]() |
AllStringMaterials | |
![]() ![]() |
AvailableObjectsMaterials | |
![]() ![]() |
AvailableStringMaterials | |
![]() ![]() |
Cast | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteMaterial | |
![]() ![]() |
DeleteMaterial(String, Database, Boolean) | |
![]() |
DeleteUnmanagedObject | (Inherited from BIMObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetBimAssets | |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetInformationAssets | |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() ![]() |
GetMaterial | |
![]() |
GetPhysicalAssets | |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() ![]() |
HasMaterial | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsNull | (Overrides BIMObjectIsNull.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
SaveMaterial | |
![]() ![]() |
SaveMaterial(BIMMaterial, Database, Boolean) | |
![]() |
SetNull | (Overrides BIMObjectSetNull.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() ![]() |
Equality | |
![]() ![]() |
Inequality |
© Bricsys NV. All rights reserved. |