GIRasterImage Class

Inheritance Hierarchy
Namespace:  Teigha.GraphicsInterface
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public class GIRasterImage : RXObject

The GIRasterImage type exposes the following members.

Constructors
  Name Description
Protected method GIRasterImage
Initializes a new instance of the GIRasterImage class
Top
Properties
Methods
  Name Description
Public methodStatic member CalcBMPScanLineSize
Public method ChangeImageSource
Public method ChangeTransparencyMode
Public method Convert(Boolean)
Public method Convert(Boolean, Double)
Public method Convert(Boolean, Double, Double)
Public method Convert(Boolean, Double, Double, Double)
Public method Convert(Boolean, Double, Double, Double, Color)
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean)
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean)
Public method Convert(Boolean, Double, Double, Double, Color, Boolean, Boolean, Boolean, GIRasterImage)
Public method Crop
Public method DefaultResolution
Protected method DeleteUnmanagedObject (Overrides RXObjectDeleteUnmanagedObject.)
Public method getColor
Public method PaletteData
Public method pixelFormat
Public method ScanLines
Public method ScanLines(Int32, Int32)
Top
See Also

©  Bricsys NV. All rights reserved.