Extents3d Structure

This class represents 3D bounding boxes as minimum and maximum 3D points for various graphical objects.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.DatabaseServicesExtents3d

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Extents3d

The Extents3d type exposes the following members.

Constructors
  Name Description
Public method Extents3d Constructor for the Extents3d class. Creates extents from the specified points.
Top
Properties
  Name Description
Public property MaxPoint Property that represents the maximum point of this extents.
Public property MinPoint Property that represents the minimum point of this extents.
Top
Methods
  Name Description
Public method AddBlockExtents Unites the bounding box that encloses all entities stored in the specified block and the bounding box of this object.
Public method AddExtents Expands this extents object by the bounding box defined by the specified object.
Public method AddPoint Expands this extents object by the specified point.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method ExpandBy Updates the extents of this Extents object by the specified vector.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(Extents3d) Compares this object to another object.
Public method IsEqualTo(Extents3d, Tolerance) Compares this object to another object within the specified tolerance.
Public method Set Sets the minimum and maximum points for this Extents object.
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Public method ToString(String, IFormatProvider) Returns an equivalent string representation of this object.
Public method TransformBy Applies the 3D transformation matrix to the extents.
Top
Operators
  Name Description
Public operatorStatic member Equality(Extents3d, Extents3d) Equality operator for the Extents3d class. Checks whether the passed objects are equal.
Public operatorStatic member Inequality(Extents3d, Extents3d) Inequality operator for the Extents3d class. Checks whether the passed objects are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.