BIMMaterial Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMMaterial

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMMaterial : BIMObject

The BIMMaterial type exposes the following members.

Constructors
  Name Description
Public method BIMMaterial Initializes a new instance of the BIMMaterial class
Public method BIMMaterial(BIMMaterial) Initializes a new instance of the BIMMaterial class
Public method BIMMaterial(String) Initializes a new instance of the BIMMaterial class
Top
Properties
  Name Description
Public property Appearance  
Public property Comments  
Public property CutPattern  
Public property SurfacePattern  
Top
Methods
  Name Description
Public methodStatic member AllObjectsMaterials  
Public methodStatic member AllStringMaterials  
Public methodStatic member AvailableObjectsMaterials  
Public methodStatic member AvailableStringMaterials  
Public methodStatic member Cast  
Public method DeleteMaterial  
Public methodStatic member DeleteMaterial(String, Database, Boolean)  
Public method GetBimAssets  
Public method GetInformationAssets  
Public methodStatic member GetMaterial  
Public method GetPhysicalAssets  
Public methodStatic member HasMaterial  
Public method SaveMaterial  
Public methodStatic member SaveMaterial(BIMMaterial, Database, Boolean)  
Public method SetToNull
(Overrides BIMObjectSetToNull)
Top
Operators
See Also

©  Bricsys NV. All rights reserved.