SweepOptionsBuilder Class

This class is used for setting options used by the createSweptSurface() and createSweptSolid() methods. The options influence the shape of the created surface or solid.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesSweepOptionsBuilder

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class SweepOptionsBuilder

The SweepOptionsBuilder type exposes the following members.

Constructors
  Name Description
Public method SweepOptionsBuilder Default constructor for the SweepOptionsBuilder class.
Public method SweepOptionsBuilder(SweepOptions) Constructor for the SweepOptionsBuilder class. Assigns the passed sweep options.
Top
Properties
  Name Description
Public property Align Property that represents the sweep options of the builder.
Public property AlignAngle Property that represents the align angle in radians.
Public property AlignStart Property that indicates whether to align at the start or the end of the curve.
Public property Bank Property that indicates whether the sweep face or curve is banked along the sweep path.
Public property BasePoint Property that represents the base point for alignment.
Public property CheckIntersections Property that indicates whether to check the swept surface or solid for self-intersections.
Public property DraftAngle Property that represents the draft angle (in radians) by which the profile tapers as it is swept.
Public property EndDraftDist Property that represents the end draft distance.
Public property PathEntityTransform Property that represents the transformation matrix of the path curve.
Public property ScaleFactor Property that represents the scale factor for the sweep operation.
Public property StartDraftDist Property that represents the start draft distance.
Public property SweepEntityTransform Property that represents the transformation matrix of the coordinate system for the swept entity.
Public property TwistAngle Property that represents the twist angle (in radians) by which the profile is twisted as it is swept.
Top
Methods
  Name Description
Public method SetPathEntityTransform Sets the coordinate system at the start and end of the path curve.
Public method SetSweepEntityTransform Sets the coordinate system at the start and end of the path curve.
Public method ToSweepOptions Retrieves the sweep options associated with this builder.
Top
See Also

©  Bricsys NV. All rights reserved.