Position2d Class

This class represents points (positions) in 2D space. For more information, see Working with Points.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryPointEntity2d
          Teigha.GeometryPosition2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Position2d : PointEntity2d

The Position2d type exposes the following members.

Constructors
  Name Description
Public method Position2d Default constructor for the Position2d class. Creates a default corresponding C++ object with no actual data stored.
Public method Position2d(Point2d) Constructor for the Position2d class. Creates a position object based on the specified point.
Public method Position2d(Double, Double) Constructor for the Position2d class. Creates a position object based on the provided coordinate values.
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method Set(Point2d) Sets coordinates of this position object based on the specified point.
Public method Set(Double, Double) Sets coordinates of this position object based on the specified coordinate values.
Top
See Also

©  Bricsys NV. All rights reserved.