Position
|
The Position3d type exposes the following members.
Name | Description | |
---|---|---|
![]() |
Position3d | Default constructor for the Position3d class. Creates a default corresponding C++ object with no actual data stored. |
![]() |
Position3d(Point3d) | Constructor for the Position3d class. Creates a position object based on the specified point. |
![]() |
Position3d(Double, Double, Double) | Constructor for the Position3d class. Creates a position object based on the provided coordinate values. |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | Clones this entity and returns a handle to the cloned
entity. (Inherited from Entity3d) |
![]() ![]() |
Create | Creates an object based on the passed pointer and returns a handle to the created object. |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetPoint | Returns a point. (Inherited from PointEntity3d) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
IsEqualTo(Entity3d) | Checks whether this entity is equal to the specified
entity. (Inherited from Entity3d) |
![]() |
IsEqualTo(Entity3d, Tolerance) | Checks whether this entity is equal to the specified entity
within a geometric tolerance. (Inherited from Entity3d) |
![]() |
IsOn(Point3d) | Checks whether the specified point is on this entity. (Inherited from Entity3d) |
![]() |
IsOn(Point3d, Tolerance) | Checks whether the specified point is on this entity according
to a geometric tolerance. (Inherited from Entity3d) |
![]() |
Mirror | Mirrors this entity about the specified plane. (Inherited from Entity3d) |
![]() |
RotateBy | Rotates this entity by the specified angle about the axis
defined by the point and the vector. (Inherited from Entity3d) |
![]() |
ScaleBy | Scales this entity by the scale factor about the specified
point. (Inherited from Entity3d) |
![]() |
Set(Point3d) | Sets coordinates of this position object based on the specified point. |
![]() |
Set(Double, Double, Double) | Sets coordinates of this position object based on the specified coordinate values. |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
TransformBy | Applies the specified 2D transformation matrix to this
entity. (Inherited from Entity3d) |
![]() |
TranslateBy | Translates this entity by applying a 3D translation
vector. (Inherited from Entity3d) |
© Bricsys NV. All rights reserved. |