DBObjectReferenceCollection Class

This class represents a collection of database object references.
Inheritance Hierarchy
SystemObject
  System.CollectionsCollectionBase
    Teigha.DatabaseServicesDBObjectReferenceCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class DBObjectReferenceCollection : CollectionBase

The DBObjectReferenceCollection type exposes the following members.

Properties
  Name Description
Public property Item Property that represents an item from the collection at the specified index.
Top
Methods
  Name Description
Public method Add Adds an object reference to the collection.
Public method Contains Checks whether this collection contains an object reference that matches the specified object reference.
Public method CopyTo Copies this object reference collection to the specified array at the specified index.
Public method IndexOf Returns the index of the object reference that matches the specified object reference in the collection.
Public method Insert Inserts the specified object reference to the collection at the provided index.
Public method Remove Removes an object reference from the collection that matches the specified object reference.
Top
See Also

©  Bricsys NV. All rights reserved.