TrimPlane Class

This class represents trim planes. A structural member can be trimmed with one or more 2D trim planes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.Aec.DatabaseServicesImpObject
          Teigha.Aec.Structural.DatabaseServicesTrimPlane

Namespace: Teigha.Aec.Structural.DatabaseServices
Assembly: TA_MgdStructure (in TA_MgdStructure.dll) Version: 0.0.0.0
Syntax
public class TrimPlane : ImpObject

The TrimPlane type exposes the following members.

Constructors
  Name Description
Public method TrimPlane Default constructor for the TrimPlane class.
Protected method TrimPlane(IntPtr, Boolean) Initializes a new instance of the TrimPlane class
Top
Properties
  Name Description
Public property End Property that represents the type of offset origin.
Public property Plane Property that represents the geometric plane parameters for trimming.
Public property PlaneNormal Property that represents the normal vector to the trim plane.
Public property PointOnPlane Property that represents an arbitrary point on the trim plane.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.