PlotStyleTable Class

This class implements plot style tables.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesPlotStyleTable

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class PlotStyleTable : RXObject

The PlotStyleTable type exposes the following members.

Properties
  Name Description
Public property AciTableAvailable Property that indicates whether an ACI table is available.
Public property ApplyScaleFactor Property that indicates whether the global scale factor is to be applied to non-ISO linetypes for this PlotStyleTable object.
Public property Description Property that represents the description of the plot style table.
Public property DisplayCustomLineweightUnits Property that indicates whether custom lineweight units are to be displayed for this PlotStyleTable object.
Public property Lineweights Property that represents a collection of lineweight values.
Public property LineweightSize  
Public property PlotStyleArr Property that represents an array of plot styles in the plot style table.
Public property PlotStyleSize Property that represents the logical length of this plot style table.
Public property ScaleFactor Property that represents the global scale factor to be applied to non-ISO linetypes for this PlotStyleTable object.
Top
Methods
  Name Description
Public method AddNewPlotStyle Adds a new plot style to the table.
Public method AddPlotStyle Adds a plot style to the table.
Public method DelPlotStyle Removes a plot style from the table.
Public method GetLineweightAt Returns the lineweight for the specified entry in this PlotStyleTable object.
Public method PlotStyleAt(Int32) Returns the specified plot style in this PlotStyleTable object.
Public method PlotStyleAt(String) Returns the specified plot style in this PlotStyleTable object.
Public method SetLineweightAt Sets the lineweight for the specified entry in this PlotStyleTable object.
Public method SetOrdering  
Top
See Also

©  Bricsys NV. All rights reserved.