BIMSpatialLocation Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMSpatialLocation
          Bricscad.BimBIMBuilding
          Bricscad.BimBIMStory

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMSpatialLocation : BIMObject

The BIMSpatialLocation type exposes the following members.

Constructors
  Name Description
Public method BIMSpatialLocation Initializes a new instance of the BIMSpatialLocation class
Public method BIMSpatialLocation(BIMBuilding) Initializes a new instance of the BIMSpatialLocation class
Public method BIMSpatialLocation(BIMSpatialLocation) Initializes a new instance of the BIMSpatialLocation class
Public method BIMSpatialLocation(BIMStory) Initializes a new instance of the BIMSpatialLocation class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member AssignedSpatialLocation  
Public method AssignToEntity  
Public methodStatic member Cast  
Public method GetAssignedObjects  
Public method HasBuilding  
Public method HasStory  
Public method IsBuilding  
Public method IsStory  
Public methodStatic member RemoveSpatialLocationFrom  
Public method SetToNull
(Overrides BIMObjectSetToNull)
Top
Operators
See Also

©  Bricsys NV. All rights reserved.