BIMBuilding Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.BimBIMObject
        Bricscad.BimBIMSpatialLocation
          Bricscad.BimBIMBuilding

Namespace: Bricscad.Bim
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class BIMBuilding : BIMSpatialLocation

The BIMBuilding type exposes the following members.

Constructors
  Name Description
Public method BIMBuilding Initializes a new instance of the BIMBuilding class
Public method BIMBuilding(BIMBuilding) Initializes a new instance of the BIMBuilding class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member AllObjectBuildings  
Public method AllObjectStories  
Public methodStatic member AllObjectStories(Database, String)  
Public methodStatic member AllStringBuildings  
Public method AllStringStories  
Public methodStatic member AllStringStories(Database, String)  
Public methodStatic member AssignedBuilding  
Public methodStatic member Cast  
Public methodStatic member CreateBuilding(Database, String)  
Public method CreateBuilding(String, Database)  
Public method CreateStory  
Public method DeleteBuilding(Database)  
Public methodStatic member DeleteBuilding(Database, String)  
Public method DeleteStory(BIMStory)  
Public method DeleteStory(String)  
Public methodStatic member GetBuilding  
Public method GetStory  
Top
Operators
See Also

©  Bricsys NV. All rights reserved.