Profile Class

AEC Profile. Contains the array of loops. Some of these loops are considered as holes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.Aec.DatabaseServicesImpObject
          Teigha.Aec.GeometryProfile

Namespace: Teigha.Aec.Geometry
Assembly: TA_Mgd (in TA_Mgd.dll) Version: 24.2.0.0
Syntax
public class Profile : ImpObject

The Profile type exposes the following members.

Constructors
  Name Description
Public method Profile Default constructor for the Profile class.
Protected method Profile(IntPtr, Boolean) Initializes a new instance of the Profile class
Top
Properties
  Name Description
Public property Area Property that represents the area of the profile.
Public property Centroid Property that represents the center of mass.
Public property RingCount Property that represents the number of rings (loops) in the profile.
Public property Rings Property that represents the array of rings (loops).
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.