DataColumn Class

This class represents a column of a DataTable.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesDataColumn

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class DataColumn : RXObject

The DataColumn type exposes the following members.

Constructors
  Name Description
Public method DataColumn Default constructor for the DataColumn class.
Public method DataColumn(DataColumn) Copy constructor for the DataColumn class.
Public method DataColumn(CellType, String) Constructor for the DataColumn class. Creates a column of a specified type and name.
Protected method DataColumn(IntPtr, Boolean) Initializes a new instance of the DataColumn class
Top
Properties
  Name Description
Public property ColumnName  
Public property ColumnType  
Public property GrowLength  
Public property NumCells  
Public property PhysicalLength  
Top
Methods
  Name Description
Public method AppendCell Appends the specified cell to the end of the column.
Public method Assign Assigns a new column to this object.
Public method GetCellAt Returns a data cell at the specified index.
Public method GetIndexAtCell Returns an index in the column that matches the data of the specified data cell. This method returns an index of the first match when there are several matches.
Public method InsertCellAt Inserts a data cell at the specified index.
Public method RemoveCellAt Removes a data cell at the specified index.
Public method SetCellAt Sets a data cell at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.