AbstractViewTableRecord Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class AbstractViewTableRecord : SymbolTableRecord

The AbstractViewTableRecord type exposes the following members.

Constructors
  Name Description
Protected method AbstractViewTableRecord
Initializes a new instance of the AbstractViewTableRecord class
Top
Properties
  Name Description
Public property AmbientLightColor
Public property BackClipDistance
Public property BackClipEnabled
Public property Background
Public property Brightness
Public property CenterPoint
Public property Contrast
Public property DefaultLightingOn
Public property DefaultLightingType
Public property Elevation
Public property FrontClipAtEye
Public property FrontClipDistance
Public property FrontClipEnabled
Public property Height
Public property LensLength
Public property PerspectiveEnabled
Public property RenderMode
Public property SunId
Public property Target
Public property Ucs
Public property UcsName
Public property UcsOrthographic
Public property ViewDirection
Public property ViewOrthographic
Public property ViewTwist
Public property VisualStyleId
Public property Width
Top
Methods
  Name Description
Public method SetSun
Public method SetUcs(ObjectId)
Public method SetUcs(OrthographicView)
Public method SetUcs(Point3d, Vector3d, Vector3d)
Public method SetUcsToWorld
Public method SetViewDirection
Top
Events
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.