Wall
|
The WallStyleComponent type exposes the following members.
Name | Description | |
---|---|---|
![]() |
WallStyleComponent | Default constructor for the WallStyleComponent class. |
![]() |
WallStyleComponent(IntPtr, Boolean) | Initializes a new instance of the WallStyleComponent class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() |
Database | Property that represents the database owning this object. (Inherited from ImpObject) |
![]() |
Description | Property that represents the description text of the
object. (Inherited from ImpObject) |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
MaterialId | Property that represents a material ObjectId applied to the wall style component. |
![]() |
Name | Property that represents the name of the wall style component. |
![]() |
Position | Property that represents the position of the wall component relative to the wall baseline and other adjacent components. |
![]() |
Priority | Property that represents the cleanup priority of the wall style component. Components with a higher priority (that have a low priority number) cut through components with a lower priority (that have a high priority number). |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject) |
![]() |
CompareTo | (Inherited from RXObject) |
![]() |
CopyFrom | (Inherited from RXObject) |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetRXClass | (Inherited from RXObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
QueryX | (Inherited from RXObject) |
![]() |
SetToStandard | Sets this object to be in the specified database. (Inherited from ImpObject) |
![]() |
SubSetDatabaseDefaults | Sets this object to be in the specified database. (Inherited from ImpObject) |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
![]() |
X | (Inherited from RXObject) |
© Bricsys NV. All rights reserved. |