ExportContext Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.IfcExportContext

Namespace: Bricscad.Ifc
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class ExportContext : DisposableWrapper

The ExportContext type exposes the following members.

Properties
  Name Description
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method GetAxis2Placement2D  
Public method GetAxis2Placement3D  
Public method GetCartesianPoint2D  
Public method GetCartesianPoint3D  
Public method GetDatabase  
Public method GetDirection2D  
Public method GetDirection3D  
Public method GetIfcModel  
Public method GetProduct(FullSubentityPath)  
Public method GetProduct(ObjectId)  
Public method SetIfcRootData  
Public method SetLocationRelToAssignedSpatialLocation  
Public method SetLocationRelToBuilding  
Public method SetLocationRelToStory  
Public method SetLocationRelToWCS  
Public method SetMaterialToAssignedComposition  
Public method SetMaterialToComposition  
Public method SetRepresentationAsBrep  
Public method SetRepresentationAsClippedExtrudedAreaSolid  
Public method SetRepresentationAsExtrudedAreaSolid  
Top
See Also

©  Bricsys NV. All rights reserved.