AcadSectionTypeSettingsClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadSectionTypeSettingsClass

Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public class AcadSectionTypeSettingsClass : IAcadSectionTypeSettings2, 
        AcadSectionTypeSettings, IAcadObjectEvents_Event, IAcadSectionTypeSettings

The AcadSectionTypeSettingsClass type exposes the following members.

Properties
  Name Description
Public property BackgroundLinesColor  
Public property BackgroundLinesHiddenLine  
Public property BackgroundLinesLayer  
Public property BackgroundLinesLinetype  
Public property BackgroundLinesLinetypeScale  
Public property BackgroundLinesLineweight  
Public property BackgroundLinesPlotStyleName  
Public property BackgroundLinesVisible  
Public property CurveTangencyLinesColor  
Public property CurveTangencyLinesLayer  
Public property CurveTangencyLinesLinetype  
Public property CurveTangencyLinesLinetypeScale  
Public property CurveTangencyLinesLineweight  
Public property CurveTangencyLinesPlotStyleName  
Public property CurveTangencyLinesVisible  
Public property DestinationBlock  
Public property DestinationFile  
Public property ForegroundLinesColor  
Public property ForegroundLinesEdgeTransparency  
Public property ForegroundLinesFaceTransparency  
Public property ForegroundLinesHiddenLine  
Public property ForegroundLinesLayer  
Public property ForegroundLinesLinetype  
Public property ForegroundLinesLinetypeScale  
Public property ForegroundLinesLineweight  
Public property ForegroundLinesPlotStyleName  
Public property ForegroundLinesVisible  
Public property GenerationOptions  
Public property IAcadSectionTypeSettings_BackgroundLinesColor  
Public property IAcadSectionTypeSettings_BackgroundLinesHiddenLine  
Public property IAcadSectionTypeSettings_BackgroundLinesLayer  
Public property IAcadSectionTypeSettings_BackgroundLinesLinetype  
Public property IAcadSectionTypeSettings_BackgroundLinesLinetypeScale  
Public property IAcadSectionTypeSettings_BackgroundLinesLineweight  
Public property IAcadSectionTypeSettings_BackgroundLinesPlotStyleName  
Public property IAcadSectionTypeSettings_BackgroundLinesVisible  
Public property IAcadSectionTypeSettings_CurveTangencyLinesColor  
Public property IAcadSectionTypeSettings_CurveTangencyLinesLayer  
Public property IAcadSectionTypeSettings_CurveTangencyLinesLinetype  
Public property IAcadSectionTypeSettings_CurveTangencyLinesLinetypeScale  
Public property IAcadSectionTypeSettings_CurveTangencyLinesLineweight  
Public property IAcadSectionTypeSettings_CurveTangencyLinesPlotStyleName  
Public property IAcadSectionTypeSettings_CurveTangencyLinesVisible  
Public property IAcadSectionTypeSettings_DestinationBlock  
Public property IAcadSectionTypeSettings_DestinationFile  
Public property IAcadSectionTypeSettings_ForegroundLinesColor  
Public property IAcadSectionTypeSettings_ForegroundLinesEdgeTransparency  
Public property IAcadSectionTypeSettings_ForegroundLinesFaceTransparency  
Public property IAcadSectionTypeSettings_ForegroundLinesHiddenLine  
Public property IAcadSectionTypeSettings_ForegroundLinesLayer  
Public property IAcadSectionTypeSettings_ForegroundLinesLinetype  
Public property IAcadSectionTypeSettings_ForegroundLinesLinetypeScale  
Public property IAcadSectionTypeSettings_ForegroundLinesLineweight  
Public property IAcadSectionTypeSettings_ForegroundLinesPlotStyleName  
Public property IAcadSectionTypeSettings_ForegroundLinesVisible  
Public property IAcadSectionTypeSettings_GenerationOptions  
Public property IAcadSectionTypeSettings_IntersectionBoundaryColor  
Public property IAcadSectionTypeSettings_IntersectionBoundaryDivisionLines  
Public property IAcadSectionTypeSettings_IntersectionBoundaryLayer  
Public property IAcadSectionTypeSettings_IntersectionBoundaryLinetype  
Public property IAcadSectionTypeSettings_IntersectionBoundaryLinetypeScale  
Public property IAcadSectionTypeSettings_IntersectionBoundaryLineweight  
Public property IAcadSectionTypeSettings_IntersectionBoundaryPlotStyleName  
Public property IAcadSectionTypeSettings_IntersectionFillColor  
Public property IAcadSectionTypeSettings_IntersectionFillFaceTransparency  
Public property IAcadSectionTypeSettings_IntersectionFillHatchAngle  
Public property IAcadSectionTypeSettings_IntersectionFillHatchPatternName  
Public property IAcadSectionTypeSettings_IntersectionFillHatchPatternType  
Public property IAcadSectionTypeSettings_IntersectionFillHatchScale  
Public property IAcadSectionTypeSettings_IntersectionFillHatchSpacing  
Public property IAcadSectionTypeSettings_IntersectionFillLayer  
Public property IAcadSectionTypeSettings_IntersectionFillLinetype  
Public property IAcadSectionTypeSettings_IntersectionFillLinetypeScale  
Public property IAcadSectionTypeSettings_IntersectionFillLineweight  
Public property IAcadSectionTypeSettings_IntersectionFillPlotStyleName  
Public property IAcadSectionTypeSettings_IntersectionFillVisible  
Public property IAcadSectionTypeSettings_SourceObjects  
Public property IntersectionBoundaryColor  
Public property IntersectionBoundaryDivisionLines  
Public property IntersectionBoundaryLayer  
Public property IntersectionBoundaryLinetype  
Public property IntersectionBoundaryLinetypeScale  
Public property IntersectionBoundaryLineweight  
Public property IntersectionBoundaryPlotStyleName  
Public property IntersectionBoundaryVisible  
Public property IntersectionFillColor  
Public property IntersectionFillFaceTransparency  
Public property IntersectionFillHatchAngle  
Public property IntersectionFillHatchPatternName  
Public property IntersectionFillHatchPatternType  
Public property IntersectionFillHatchScale  
Public property IntersectionFillHatchSpacing  
Public property IntersectionFillLayer  
Public property IntersectionFillLinetype  
Public property IntersectionFillLinetypeScale  
Public property IntersectionFillLineweight  
Public property IntersectionFillPlotStyleName  
Public property IntersectionFillVisible  
Public property SourceObjects  
Top
Methods
  Name Description
Public method add_Modified  
Public method remove_Modified  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.