Viewport Class

This class represents the view characteristics of the current viewport within the ODA Platform vectorization framework. Client code can query this information to generate the correct viewport-dependent geometric representation for an object.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.GraphicsInterfaceViewport

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Viewport : RXObject

The Viewport type exposes the following members.

Constructors
  Name Description
Protected method Viewport Initializes a new instance of the Viewport class
Top
Properties
Methods
  Name Description
Public method DoInversePerspective Applies the inverse of the current perspective transformation to the specified point.
Public method DoPerspective Applies the current perspective transformation to the specified point.
Public method GetNumPixelsInUnitSquare Returns the display pixel density at the specified point for this Viewport object.
Public method LayerVisible Checks whether the specified layer is not frozen either globally or in this Viewport object.
Top
See Also

©  Bricsys NV. All rights reserved.