Parameter Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.ParametricParameter

Namespace: Bricscad.Parametric
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class Parameter : DisposableWrapper

The Parameter type exposes the following members.

Properties
  Name Description
Public property BlockId returns the owner block table record of this parameter
Public property ExposeMode return the current value of Exposed attribute of this parameter
Public property Expression returns and sets the expression of this parameter
Public property GeometryDrivenMode return the current value of Geometry-driven flag of this parameter
Public property HasLowerBound returns whether this parameter has the lower bound or not
Public property HasUpperBound returns whether this parameter has the upper bound or not
Public property IsAnonymous returns whether this parameter is anonymous or not
Public property LowerBound returns the lower bound of this parameter
Public property Name returns and sets the name of this parameter
Public property UpperBound returns the upper bound of this parameter
Public property Value returns the last successful result of the evaluation of the parameter of this parameter
Top
Methods
  Name Description
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method erase erase this constraints variable
Public methodStatic member GetByName returns the constraint parameter from specified block table record, by parameter name
Public methodStatic member GetFromBlock returns all parameters from specified block table record
Public method UnsetLowerBound  
Public method UnsetUpperBound  
Top
See Also

©  Bricsys NV. All rights reserved.